Status | Blacksmith - GitHub Actions checkout are taking longer than usual – Incident details

GitHub Actions checkout are taking longer than usual

Monitoring
Degraded performance
Started about 16 hours ago

Affected

Github → Actions

Updates
  • Monitoring
    Monitoring

    Our upstream ISP identified some issues between them and their network vendor. They have made changes to mitigate these blips while working on a longer term resolution. We will share more details as we receive them. All network operations in Blacksmith runners have returned to normal. We are actively monitoring the situation.

  • Update
    Update

    We are being alerted about intermittent degradation in our network stack in one of our regions. This may be sporadically manifesting as slower docker pulls, interactions with certain language mirrors, git checkouts. We are investigating the source of this issue.

  • Investigating
    Investigating
    We're hearing this from several customers today that they are seeing elevated `actions/checkout` times. We are noticing this in our local development as well. This is very likely an upstream degradation with the GItHub control plane but we are investigating what we can do to mitigate these.