Status | Blacksmith - Occasional failures during setup of GitHub Actions jobs on Blacksmith runners – Incident details

Occasional failures during setup of GitHub Actions jobs on Blacksmith runners

Resolved
Degraded performance
Started 6 days agoLasted about 3 hours

Affected

Blacksmith Managed Runners

Degraded performance from 11:07 AM to 12:16 PM, Operational from 12:16 PM to 2:08 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved we will be gradually re-enabling transparent caching for all orgs.

  • Monitoring
    Monitoring

    We are implementing a fix to re-enable transparent caching for all orgs. There should be no customer facing impact any more.

  • Identified
    Identified

    The issue appears to be related to the setup of our caching backend. We will temporarily disable transparent caching to prevent setup of GitHub Actions from failing. This will not affect customers that are using our useblacksmith/cache or useblacksmith/setup-* actions.

  • Investigating
    Investigating

    We are being notified of occasional failures in the setup step of GitHub Actions jobs on Blacksmith runners. We are investigating the cause of this flakiness.