Status | Blacksmith - Jobs hanging on `git checkout` step in GitHub workflows – Incident details

Jobs hanging on `git checkout` step in GitHub workflows

Resolved
Degraded performance
Started 9 days agoLasted about 1 hour

Affected

Blacksmith Managed Runners
Updates
  • Resolved
    Resolved

    This incident has been resolved, our US runners are back to having normal download times. This was caused due to an upstream networking flake with our data centre provider.

  • Investigating
    Investigating

    We have been alerted of some instances of the git checkout step hanging on runners in our US fleet. We are looking into the issue and will post an update once we have understood the cause.