blacksmith - GitHub Outage Affecting Jobs – Incident details

GitHub Outage Affecting Jobs

Resolved
Major outage
Started about 1 month agoLasted about 4 hours

Affected

Github → Actions

Operational from 11:38 PM to 3:54 AM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    Job executions have returned to normal. We are monitoring the recovery.

  • Update
    UTC
    Update

    Requests to GitHub API are now succeeding. There maybe some some delays in job adoption as we work through the large backlog of jobs that did not run during the incident.

  • Update
    UTC
    Update

    We are starting to see signs of recovery of upstream API errors and jobs have resumed running. We are continuing to monitor.

  • Update
    UTC
    Update

    We are continuing to see errors from GitHub when trying to provision CI jobs. They are continuing to investigate their incident.

    https://www.githubstatus.com/incidents/8vfyvq16hzh9

  • Identified
    UTC
    Identified

    GitHub has opened an incident which we are seeing is affecting jobs getting picked up.

    https://www.githubstatus.com/incidents/8vfyvq16hzh9