Status | Blacksmith - GitHub Actions Degraded Availability – Incident details

GitHub Actions Degraded Availability

Resolved
Major outage
Started about 2 months agoLasted about 3 hours

Affected

Github → Actions

Degraded performance from 4:46 PM to 7:13 PM, Operational from 7:13 PM to 7:23 PM

Github → API Requests

Operational from 4:46 PM to 5:11 PM, Major outage from 5:11 PM to 7:13 PM, Operational from 7:13 PM to 7:23 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    Upstream incident is resolved. There may be slightly elevated wait times for jobs to be picked up as the last of the incident backlog is caught up.

  • Monitoring
    Monitoring

    We are seeing recovery from GitHub's APIs and jobs getting picked up again. We expect a bit of a backlog as jobs get run from during the incident duration.

  • Identified
    Identified

    We are seeing severe degradation in GitHub API causing jobs to not get picked up.

  • Investigating
    Investigating

    GitHub has declared Actions is experiencing Degraded Availability and indicated multiple services are experiencing service degradation. We're tracking this incident and will provide updates as GitHub provides them.

    https://www.githubstatus.com/incidents/g5gnt5l5hf56