Status | Blacksmith - Github Actions are experiencing Degraded Performance – Incident details

Github Actions are experiencing Degraded Performance

Resolved
Major outage
Started about 2 months agoLasted about 2 hours

Affected

Github → Actions

Github → API Requests

Github → Webhooks

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    Github has reported they are seeing full recovery in many systems, but delays are still expected for actions. We will continue to update.

  • Update
    Update

    Github has identified a faulty network component as the cause and is seeing recovery of some services. API Requests are now operating normally.

  • Update
    Update

    GitHub is experiencing major outages across a variety of services (including Webhooks, Actions, and API Requests). This outage is impacting our ability to process jobs since we rely on Webhooks. We are continuing to monitor the situation closely and will provide updates as we receive them.

  • Update
    Update

    We're seeing major performance degradation due to an outage from Github Actions and Webhooks. We are continuing to monitor for updates.

  • Monitoring
    Monitoring

    Github Actions is experiencing degraded performance. We're monitoring Github's incident here: https://www.githubstatus.com/incidents/k7bhmjkblcwp