Status | Blacksmith - GitHub reporting upstream degradation in Actions – Incident details

GitHub reporting upstream degradation in Actions

Resolved
Degraded performance
Started 3 months agoLasted about 1 hour

Affected

Blacksmith Managed Runners

Operational from 1:47 PM to 2:27 PM, Degraded performance from 2:27 PM to 2:47 PM

Github → Actions

Updates
  • Resolved
    Resolved

    This incident has been resolved, queue times have returned to normal.

  • Identified
    Identified

    GitHub has resolved the incident but we're seeing some downstream backlog of jobs being assigned to our runners. This is causing increased queue times for some orgs running in the EU.

  • Investigating
    Investigating

    GitHub has declared an incident with their Actions service. We are monitoring for any downstream impact on Blacksmith runners - https://www.githubstatus.com/incidents/s9t1dgymd4v9