Status | Blacksmith - Reports of job setup failing due to network degradation – Incident details

Reports of job setup failing due to network degradation

Resolved
Degraded performance
Started 3 months agoLasted about 1 hour

Affected

Blacksmith Managed Runners

Degraded performance from 6:08 PM to 6:16 PM, Operational from 6:16 PM to 7:10 PM

Github → Actions

Github → API Requests

Updates
  • Resolved
    Resolved

    This incident has been resolved, runners are consistently working as expected.

  • Monitoring
    Monitoring

    We are seeing signs of recovery, jobs are consistently being able to setup their environments and pull artifacts. We are continuing to monitor the situation until all our monitoring returns to its baseline.

  • Update
    Update

    We are seeing degradation across both our US and EU fleets, which are on different networking stacks. This suggests that there is a degradation on GitHub's end, as can be seen on downdetector - https://downdetector.com/status/github/. We're still investigating on our end.

  • Investigating
    Investigating

    We are seeing reports of some network degradation across our fleet. It is unclear whether this is on GitHub's end or not. We are looking into the issue.