Status | Blacksmith - Github `actions/checkout` is failing with `fatal: protocol error: bad pack header` when trying to pull the repository – Incident details

Github `actions/checkout` is failing with `fatal: protocol error: bad pack header` when trying to pull the repository

Resolved
Degraded performance
Started 3 months agoLasted about 1 hour

Affected

Blacksmith Managed Runners
Github → Actions
Updates
  • Resolved
    Resolved

    This incident has been resolved by GitHub, operations should be back to normal.

  • Identified
    Identified

    GitHub has opened an incident, we will continue monitoring the status of this - https://www.githubstatus.com/incidents/q3xqwmcxzkqq

  • Investigating
    Investigating

    Both GitHub hosted runners and Blacksmith hosted runners are seeing an error when trying to checkout the repository in a GitHub workflow. This is indicative of an outage or bad deploy on GitHub's end, we are monitoring the situation.