Status | Blacksmith - Delay in GitHub assigning jobs resulting in queueing – Incident details

Delay in GitHub assigning jobs resulting in queueing

Resolved
Partial outage
Started 5 days agoLasted about 1 hour

Affected

GitHub Action Runners

Operational from 4:49 AM to 4:55 AM, Partial outage from 4:55 AM to 5:12 AM, Operational from 5:12 AM to 5:48 AM

API

Operational from 4:49 AM to 5:48 AM

Website

Operational from 4:49 AM to 5:48 AM

Github → Actions

Github → API Requests

Github → Webhooks

Updates
  • Resolved
    Resolved

  • Monitoring
    Monitoring

    There seems to be signs of recovery with GitHub now assigning jobs to newly triggered runs. It is possible that previously queued jobs will have to be canceled and retried to get them to run.

  • Investigating
    Update

    GitHub is not assigning any jobs to our runners, we're escalating this to an outage while we wait for them to report an issue on their end.

  • Investigating
    Investigating

    We are noticing GitHub taking several minutes to assign our runners a job, we are monitoring the situation.