blacksmith - Intermittent dashboard loading and CI job errors due to GitHub outage – Incident details

Intermittent dashboard loading and CI job errors due to GitHub outage

Resolved
Partial outage
Started about 1 month agoLasted about 1 hour

Affected

Website

Updates
  • Resolved
    UTC
    Resolved

    The upstream GitHub incident has been resolved: https://www.githubstatus.com/

    We will continue to monitor GitHub API Stability.

  • Monitoring
    UTC
    Monitoring

    We are seeing errors affecting the availability to log into the Blacksmith dashboard due to upstream calls to GitHub. There are widespread reports of GitHub API failures: https://www.githubstatus.com/ | https://updog.ai/status/github

    We are seeing this impact CI jobs that interact with GitHub APIs such as downloading actions, uploading artifacts, etc.

  • Identified
    UTC
    Identified

    We are seeing errors affecting the availability to log into the Blacksmith dashboard due to upstream calls to GitHub. We are not currently seeing any impact to the execution of CI jobs.

  • Investigating
    UTC
    Investigating
    We are currently investigating this incident.