Status | Blacksmith - Elevated tail latency in git checkout operations – Incident details

Elevated tail latency in git checkout operations

Resolved
Major outage
Started 1 day agoLasted about 2 hours

Affected

Blacksmith Managed Runners

Degraded performance from 6:22 PM to 8:30 PM

US ARM

Degraded performance from 6:22 PM to 8:30 PM

US X86

Degraded performance from 6:22 PM to 8:30 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved, checkout operations are back to their baseline.

  • Monitoring
    Monitoring

    The upstream degradation has been resolved, we are seeing checkout times return to normal.

  • Identified
    Identified

    We have been made aware of an upstream degradation in our US West region by our network provider. This is manifesting as some % of git checkout operations taking much longer than their baseline. We are working with our upstream provider to restore functionality.