Status | Blacksmith - Delays in Job Adoption & Degraded Git Operations – Incident details

Experiencing partially degraded performance

Delays in Job Adoption & Degraded Git Operations

Monitoring
Degraded performance
Started about 7 hours ago

Affected

Blacksmith Managed Runners

Degraded performance from 9:19 PM to 12:00 AM

EU ARM

Degraded performance from 9:19 PM to 12:00 AM

EU X86

Degraded performance from 9:19 PM to 12:00 AM

US ARM

Degraded performance from 9:19 PM to 12:00 AM

US X86

Degraded performance from 9:19 PM to 12:00 AM

Github → Actions

Operational from 9:19 PM to 9:32 PM, Degraded performance from 9:32 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    We're seeing signs of recovery and are continuing to monitor.

  • Update
    Update

    We are continuing to investigate delays in job adoption and degraded Git interactions, mostly for Checkout actions.

    This appears to be related to an upstream GitHub outage. We are monitoring the situation and will provide updates as more information becomes available.

  • Investigating
    Investigating

    We are investigating reports of delays in jobs being adopted and degraded interactions with GitHub services.