Status | Blacksmith - Timeouts reported when downloading certain actions from GitHub – Incident details

Timeouts reported when downloading certain actions from GitHub

Resolved
Degraded performance
Started 1 day agoLasted about 1 hour

Affected

Github → Actions

Github → API Requests

Updates
  • Resolved
    Resolved

    This incident has been resolved, we are no longer seeing signs of this flake with GitHub.

  • Investigating
    Investigating

    We are being alerted of timeouts when downloading the different actions used in your workflow file from GitHub. This usually indicates some sort of upstream degradation in GitHub's control plane