Status | Blacksmith - GitHub returning 429s when downloading first party actions – Incident details

GitHub returning 429s when downloading first party actions

Resolved
Degraded performance
Started about 1 month agoLasted about 10 hours

Affected

Github → Actions

Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    This incident has been resolved by GitHub.

  • Identified
    Identified
    GitHub have declared an upstream incident, we will continue monitoring these failures we are seeing sporadically.
  • Investigating
    Investigating

    We are monitoring reports of GitHub returning 429s when downloading first party actions such as actions/setup-go etc. The error string being reported is of the form:
    ```
    Error: Response status code does not indicate success: 429 (Too Many Requests). DC04:39E04E:636AE0:858F56:6887975E
    ```