Status | Blacksmith - Increased queueing in our US region – Incident details

Increased queueing in our US region

Resolved
Degraded performance
Started about 1 month agoLasted 4 minutes

Affected

Blacksmith Managed Runners

Degraded performance from 3:06 PM to 3:10 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved, queue times are back to normal.

  • Investigating
    Investigating

    We are currently investigating signs of increased queue times in our US region.