Status | Blacksmith - Gateway timeout errors on actions checkout – Incident details

Gateway timeout errors on actions checkout

Resolved
Partial outage
Started 10 days agoLasted about 1 hour

Affected

Blacksmith Managed Runners

Operational from 12:18 AM to 1:25 AM

Github → Actions

Github → API Requests

Github → Webhooks

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We're seeing signs of recovery and are seeing a much lower frequency of errors from the GitHub control plane. We're closely monitoring the situation.

  • Update
    Update

    We're seeing signs of a partial outage with multiple GitHub services.

  • Investigating
    Investigating

    We're observing some errors with GitHub's servers on actions checkouts within workflow jobs. They may look like the following:
    ```
    Failed to download action 'https://api.github.com/repos/useblacksmith/cache/tarball/42576a590105e3d6c1afc15517cc51161d06a321'. Error: Response status code does not indicate success: 504 (Gateway Timeout).
    ```

    We're investigating this incident.