Status | Blacksmith - Incident with GitHub Actions – Incident details

Incident with GitHub Actions

Resolved
Degraded performance
Started about 1 month agoLasted about 2 hours

Affected

Github → Actions

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    GitHub posted an update

    "We have remediated the issue impacting Actions workflows. During investigation and remediation, we realized there were also issues with recording metadata around merge commits. No git data or code has been lost. PRs merged today between 20:06 UTC and 22:15 UTC are impacted. We are working on a plan to regenerate the missing metadata and will provide an update once we have one in place."

    We are not observing any direct impact on Blacksmith runners at the moment.

    https://www.githubstatus.com/incidents/6ddp6v8g5t72

  • Monitoring
    Monitoring

    GitHub has reported an active incident with Actions: https://www.githubstatus.com/incidents/6ddp6v8g5t72

    We're monitoring its status and keeping an eye on its impact on our services.