Status | Blacksmith - Major GitHub outage – Incident details

Github → Actions experiencing degraded performance

Major GitHub outage

Resolved
Major outage
Started 3 months agoLasted about 1 hour

Affected

Blacksmith Managed Runners

Operational from 11:29 PM to 12:31 AM

API

Operational from 11:29 PM to 12:31 AM

Website

Operational from 11:29 PM to 12:31 AM

Github → Actions

Github → API Requests

Github → Webhooks

Updates
  • Resolved
    Resolved

    This incident has been marked resolved by GitHub, jobs are running on Blacksmith normally again. We will continue to monitor any fallout from this outage.

  • Identified
    Identified

    GitHub is rolling back its database infrastructure change. They said they are seeing service health improvements and monitoring for a full recovery. https://www.githubstatus.com/incidents/kz4khcgdsfdv

  • Investigating
    Investigating

    GitHub has reported a major outage https://www.githubstatus.com/incidents/kz4khcgdsfdv